<!doctype html>
<html lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>5 Reasons to Keep Watching &#039;All Creatures Great and Small&#039; - GeekMom</title>
	<meta name="description" content="Season 2 of &#039;All Creatures Great and Small&#039; is now available in the U.S. If you haven&#039;t started watching, here are some reasons to catch up." />
	<link rel="canonical" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="5 Reasons to Keep Watching &#039;All Creatures Great and Small&#039; - GeekMom" />
	<meta property="og:description" content="Season 2 of &#039;All Creatures Great and Small&#039; is now available in the U.S. If you haven&#039;t started watching, here are some reasons to catch up." />
	<meta property="og:url" content="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/" />
	<meta property="og:site_name" content="GeekMom" />
	<meta property="article:publisher" content="https://facebook.com/geekmomblog/" />
	<meta property="article:published_time" content="2022-01-30T13:00:48+00:00" />
	<meta property="article:modified_time" content="2022-01-31T05:30:39+00:00" />
	<meta property="og:image" content="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="900" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@geekmomblog" />
	<meta name="twitter:site" content="@geekmomblog" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Lisa Tate" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://geekmom.com/#website","url":"https://geekmom.com/","name":"GeekMom","description":"Smart. Social. Savvy.","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://geekmom.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/#primaryimage","inLanguage":"en-US","url":"https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg","contentUrl":"https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg","width":1200,"height":900,"caption":"creatures season 2 feature"},{"@type":"WebPage","@id":"https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/#webpage","url":"https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/","name":"5 Reasons to Keep Watching 'All Creatures Great and Small' - GeekMom","isPartOf":{"@id":"https://geekmom.com/#website"},"primaryImageOfPage":{"@id":"https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/#primaryimage"},"datePublished":"2022-01-30T13:00:48+00:00","dateModified":"2022-01-31T05:30:39+00:00","author":{"@id":"https://geekmom.com/#/schema/person/cceec36df012a4b14072011c6a449a50"},"description":"Season 2 of 'All Creatures Great and Small' is now available in the U.S. If you haven't started watching, here are some reasons to catch up.","breadcrumb":{"@id":"https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/"]}]},{"@type":"BreadcrumbList","@id":"https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://geekmom.com/"},{"@type":"ListItem","position":2,"name":"Recent Posts","item":"https://geekmom.com/recent-posts/"},{"@type":"ListItem","position":3,"name":"5 Reasons to Keep Watching &#8216;All Creatures Great and Small&#8217;"}]},{"@type":"Person","@id":"https://geekmom.com/#/schema/person/cceec36df012a4b14072011c6a449a50","name":"Lisa Tate","image":{"@type":"ImageObject","@id":"https://geekmom.com/#personlogo","inLanguage":"en-US","url":"https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/11/Lisa_HiRes-copy-96x96.jpg","contentUrl":"https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/11/Lisa_HiRes-copy-96x96.jpg","caption":"Lisa Tate"},"description":"Lisa Kay Tate is a veteran feature writer with nearly 25 years experience in newspaper, magazine and freelance writing. She and her husband, a history and world geography teacher, live on the edge of \"New Texico\" where they keep busy raising their two geeklings and sharing space with their dog, Sirius Black, and cat, Loki.","url":"https://geekmom.com/author/lisa/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel="amphtml" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/amp/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=5-reasons-to-keep-watching-all-creatures-great-and-small" /><meta name="generator" content="AMP for WP 1.0.77.35"/><link rel='dns-prefetch' href='//scripts.mediavine.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v7.3.2 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-39719012-2"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/geekmom.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='scap.flashblock-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/compact-wp-audio-player/css/flashblock.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='scap.player-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/compact-wp-audio-player/css/player.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='formidable-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/formidable/css/formidableforms.css?ver=1271841' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://149461325.v2.pressablecdn.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://149461325.v2.pressablecdn.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://149461325.v2.pressablecdn.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.6.0' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='dashicons-css'  href='https://149461325.v2.pressablecdn.com/wp-includes/css/dashicons.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='kodex-posts-likes-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/kodex-posts-likes/public/css/kodex-posts-likes-public.css?ver=2.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='bc_rb_global_style-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/random-banner/assets/style/bc_rb_global.css?ver=4.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='bc_rb_animate-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/random-banner/assets/style/animate.css?ver=4.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='owl.carousel-style-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/random-banner/assets/style/owl.carousel.css?ver=4.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='owl.carousel-default-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/random-banner/assets/style/owl.theme.default.css?ver=4.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='owl.carousel-transitions-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/random-banner/assets/style/owl.transitions.css?ver=4.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='custom-style-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/stackcommerce-deal-feed/wp/includes/css/custom_script.css?ver=5.9' type='text/css' media='all' />
<style id='custom-style-inline-css' type='text/css'>

                .stackCommerceWidgetSidebar .singlestackCommerceItem .stackCommerceItemPrice{
                        background: #2db500;
                        color: #ffffff;
                }
                .stackCommerceWidgetSidebar .singlestackCommerceItem {
                    background: #f7f7f7;
                }
                .stackCommerceWidgetSidebar .singlestackCommerceItem .singlestackCommerceItemDiscount {
                    background: ;
                    color: ;
                    display: block;
                }
                .stackCommerceSeeAllDeals {
                    display: block;
                }
                .stackCommerceInlineDisplayHeader .stackCommerceInlineHeaderText {
                    font-size: 40px;
                }
                .singlestackCommerceItem {
                    background: #f7f7f7;
                }
                
</style>
<link rel='stylesheet' id='news-vibrant-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300italic%2C400italic%2C700italic%2C400%2C300%2C700%7CTitillium+Web%3A400%2C600%2C700%2C300&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/library/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='lightslider-style-css'  href='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/library/lightslider/css/lightslider.min.css?ver=1.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='news-vibrant-style-css'  href='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/style.css?ver=1.0.12' type='text/css' media='all' />
<style id='news-vibrant-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='news-vibrant-responsive-style-css'  href='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/css/nv-responsive.css?ver=1.0.0' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='cb_p6-css-main-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/patron-button-and-widgets-by-codebard/plugin/templates/default/style.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.6-beta' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://149461325.v2.pressablecdn.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.6-beta' type='text/css' media='all' />
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/compact-wp-audio-player/js/soundmanager2-nodebug-jsmin.js?ver=5.9' id='scap.soundmanager2-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/out\\\/\",\"label\":\"Affiliate\"}]","home_url":"https:\/\/geekmom.com","hash_tracking":"true","ua":"UA-39719012-2","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=7.3.2' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='kodex-posts-likes-js-extra'>
/* <![CDATA[ */
var kodex_posts_likes = {"ajaxurl":"https:\/\/geekmom.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/kodex-posts-likes/public/js/kodex-posts-likes-public.js?ver=2.4.3' id='kodex-posts-likes-js'></script>
<script type='text/javascript' async="async" data-noptimize="1" data-cfasync="false" src='https://scripts.mediavine.com/tags/geek-mom.js?ver=5.9' id='mv-script-wrapper-js'></script>
<link rel="https://api.w.org/" href="https://geekmom.com/wp-json/" /><link rel="alternate" type="application/json" href="https://geekmom.com/wp-json/wp/v2/posts/339937" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://geekmom.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://geekmom.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p2jJEi-1qqR' />
<link rel="alternate" type="application/json+oembed" href="https://geekmom.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgeekmom.com%2F2022%2F01%2F5-reasons-to-keep-watching-all-creatures-great-and-small%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://geekmom.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgeekmom.com%2F2022%2F01%2F5-reasons-to-keep-watching-all-creatures-great-and-small%2F&#038;format=xml" />
		<style type="text/css">
		.feedzy-rss-link-icon:after {
			content: url( "https://149461325.v2.pressablecdn.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png" );
			margin-left: 3px;
		}
	</style>
		<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<style type="text/css">
.sfs-subscriber-count, .sfs-count, .sfs-count span, .sfs-stats { -webkit-box-sizing: initial; -moz-box-sizing: initial; box-sizing: initial; }
.sfs-subscriber-count { width: 88px; overflow: hidden; height: 26px; color: #424242; font: 9px Verdana, Geneva, sans-serif; letter-spacing: 1px; }
.sfs-count { width: 86px; height: 17px; line-height: 17px; margin: 0 auto; background: #ccc; border: 1px solid #909090; border-top-color: #fff; border-left-color: #fff; }
.sfs-count span { display: inline-block; height: 11px; line-height: 12px; margin: 2px 1px 2px 2px; padding: 0 2px 0 3px; background: #e4e4e4; border: 1px solid #a2a2a2; border-bottom-color: #fff; border-right-color: #fff; }
.sfs-stats { font-size: 6px; line-height: 6px; margin: 1px 0 0 1px; word-spacing: 2px; text-align: center; text-transform: uppercase; }
</style>
<script type="text/javascript">document.documentElement.className += " js";</script>
<style type='text/css'>img#wpstats{display:none}</style>
	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://149461325.v2.pressablecdn.com/wp-content/uploads/2020/07/cropped-geek-mom-initials-32x32.png" sizes="32x32" />
<link rel="icon" href="https://149461325.v2.pressablecdn.com/wp-content/uploads/2020/07/cropped-geek-mom-initials-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://149461325.v2.pressablecdn.com/wp-content/uploads/2020/07/cropped-geek-mom-initials-180x180.png" />
<meta name="msapplication-TileImage" content="https://149461325.v2.pressablecdn.com/wp-content/uploads/2020/07/cropped-geek-mom-initials-270x270.png" />
<style type="text/css" id="wp-custom-css">/* Begin Mediavine Sidebar Fix */
@media only screen and (min-width: 769px) {
    .right-sidebar #secondary {
        min-width: 300px !important;
    }
    .right-sidebar #primary {
        max-width: calc(100% - 330px) !important;
    }
}
@media only screen and (min-width: 980px) {
    .nv-home-middle-section .middle-primary {
        max-width: calc(71% - 300px);
    }
    .nv-home-middle-section .middle-right-aside {
        min-width: 300px;
    }
}
@media only screen and (min-width: 1201px) and (max-width: 1379px) {
    .cv-container {
        width: 1200px !important;
    }
}
@media only screen and (min-width: 1380px) {
    .cv-container {
        width: 1380px !important;
    }
}
/*End Mediavine Sidebar Fix*/
.home .nv-post-meta .comments-link {
	display: none;
}</style>
<!-- START - Heateor Open Graph Meta Tags 1.1.9 -->
<link rel="canonical" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/"/>
<meta name="description" content="Season 2 of &#039;All Creatures Great and Small&#039; is now available in the U.S. If you haven&#039;t started watching, here are some reasons to catch up."/>
<meta property="og:locale" content="en_US"/>
<meta property="og:site_name" content="GeekMom"/>
<meta property="og:title" content="5 Reasons to Keep Watching &#039;All Creatures Great and Small&#039;"/>
<meta property="og:url" content="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/"/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg"/>
<meta property="og:description" content="Season 2 of &#039;All Creatures Great and Small&#039; is now available in the U.S. If you haven&#039;t started watching, here are some reasons to catch up."/>
<meta name="twitter:title" content="5 Reasons to Keep Watching &#039;All Creatures Great and Small&#039;"/>
<meta name="twitter:url" content="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/"/>
<meta name="twitter:description" content="Season 2 of &#039;All Creatures Great and Small&#039; is now available in the U.S. If you haven&#039;t started watching, here are some reasons to catch up."/>
<meta name="twitter:image" content="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta itemprop="name" content="5 Reasons to Keep Watching &#039;All Creatures Great and Small&#039;"/>
<meta itemprop="description" content="Season 2 of &#039;All Creatures Great and Small&#039; is now available in the U.S. If you haven&#039;t started watching, here are some reasons to catch up."/>
<meta itemprop="image" content="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg"/>
<!-- END - Heateor Open Graph Meta Tags -->

</head>

<body class="post-template-default single single-post postid-339937 single-format-standard wp-custom-logo group-blog right-sidebar fullwidth_layout">

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
	
	<div class="nv-top-header-wrap"><div class="cv-container">		<div class="nv-top-left-section-wrapper">
			
					</div><!-- .nv-top-left-section-wrapper -->
		<div class="nv-top-right-section-wrapper">
			<div class="nv-social-icons-wrapper"><span class="social-link"><a href="https://twitter.com/GeekMomBlog" target="_blank" class="external" rel="nofollow"><i class="fa fa-twitter"></i></a></span><span class="social-link"><a href="https://www.facebook.com/GeekMomBlog/" target="_blank" class="external" rel="nofollow"><i class="fa fa-facebook-square"></i></a></span><span class="social-link"><a href="https://www.instagram.com/geekmomblog/" target="_blank" class="external" rel="nofollow"><i class="fa fa-instagram"></i></a></span><span class="social-link"><a href="https://www.pinterest.com/geekmomblog/" target="_blank" class="external" rel="nofollow"><i class="fa fa-pinterest"></i></a></span><span class="social-link"><a href="https://www.youtube.com/channel/UCupPm6tn4MjFA75Ri63tTDQ" target="_blank" class="external" rel="nofollow"><i class="fa fa-youtube-play"></i></a></span></div><!-- .nv-social-icons-wrapper -->		</div><!-- .nv-top-right-section-wrapper -->
</div><!-- .cv-container --></div><!-- .nv-top-header-wrap --><header id="masthead" class="site-header" role="banner"><div class="nv-logo-section-wrapper"><div class="cv-container">		<div class="site-branding">

			<a href="https://geekmom.com/" class="custom-logo-link" rel="home"><img width="286" height="45" src="https://149461325.v2.pressablecdn.com/wp-content/uploads/2020/07/cropped-geek-mom-long-1.png" class="custom-logo" alt="GeekMom" data-attachment-id="331187" data-permalink="https://geekmom.com/cropped-geek-mom-long-1-png/" data-orig-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2020/07/cropped-geek-mom-long-1.png" data-orig-size="286,45" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-geek-mom-long-1.png" data-image-description="&lt;p&gt;https://geekmom.com/wp-content/uploads/2020/07/cropped-geek-mom-long-1.png&lt;/p&gt;
" data-image-caption="" data-medium-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2020/07/cropped-geek-mom-long-1.png" data-large-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2020/07/cropped-geek-mom-long-1.png" /></a>
							<p class="site-title"><a href="https://geekmom.com/" rel="home">GeekMom</a></p>
							<p class="site-description">Smart. Social. Savvy.</p>
						
		</div><!-- .site-branding -->
		<div class="nv-header-ads-area">
			<section id="media_image-12" class="widget widget_media_image"><a href="https://www.kickstarter.com/projects/boar-games/castle-system-magnetic-tabletop-terrain-for-rpg-and-wargames" class="external" rel="nofollow" target="_blank"><img width="768" height="92" src="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/CASTLE-SYSTEM-GEEKDAD-BANNER-768X92.png" class="image wp-image-339947  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/CASTLE-SYSTEM-GEEKDAD-BANNER-768X92.png 768w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/CASTLE-SYSTEM-GEEKDAD-BANNER-768X92-600x72.png 600w " sizes="(max-width: 768px) 100vw, 768px" data-attachment-id="339947" data-permalink="https://geekmom.com/castle-system-geekdad-banner-768x92/" data-orig-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/CASTLE-SYSTEM-GEEKDAD-BANNER-768X92.png" data-orig-size="768,92" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CASTLE SYSTEM GEEKDAD BANNER 768X92" data-image-description="" data-image-caption="" data-medium-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/CASTLE-SYSTEM-GEEKDAD-BANNER-768X92-600x72.png" data-large-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/CASTLE-SYSTEM-GEEKDAD-BANNER-768X92.png" /></a></section>		</div><!-- .nv-header-ads-area -->
</div><!-- .cv-container --></div><!-- .nv-logo-section-wrapper -->		<div id="nv-menu-wrap" class="nv-header-menu-wrapper">
			<div class="nv-header-menu-block-wrap">
				<div class="cv-container">
												<div class="nv-home-icon">
								<a href="https://geekmom.com/" rel="home"> <i class="fa fa-home"> </i> </a>
							</div><!-- .nv-home-icon -->
					                    <a href="javascript:void(0)" class="menu-toggle hide"> <i class="fa fa-navicon"> </i> </a>
					<nav id="site-navigation" class="main-navigation" role="navigation">
						<div class="menu-menu-1-container"><ul id="primary-menu" class="menu"><li id="menu-item-298242" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-298242 nv-cat-2703"><a href="https://geekmom.com/category/featured-columns/">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-301253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-301253 nv-cat-18302"><a href="https://geekmom.com/category/featured-columns/geekasaurus/">Geekasaurus</a></li>
	<li id="menu-item-298244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298244 nv-cat-18276"><a href="https://geekmom.com/category/featured-columns/be-the-artist/">Be the Artist</a></li>
	<li id="menu-item-298245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298245 nv-cat-12418"><a href="https://geekmom.com/category/featured-columns/between-the-bookends/">Between the Bookends</a></li>
	<li id="menu-item-298247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298247 nv-cat-12419"><a href="https://geekmom.com/category/featured-columns/comic-book-corner/">Comic Book Corner</a></li>
	<li id="menu-item-298248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298248 nv-cat-12420"><a href="https://geekmom.com/category/featured-columns/geek-speaks-fiction/">Geek Speaks…Fiction!</a></li>
	<li id="menu-item-298249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298249 nv-cat-18273"><a href="https://geekmom.com/category/featured-columns/procrastination-destination/">Procrastination Destination</a></li>
	<li id="menu-item-298250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298250 nv-cat-7057"><a href="https://geekmom.com/category/featured-columns/puzzle-of-the-week/">Puzzle of the Week</a></li>
	<li id="menu-item-298251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298251 nv-cat-12421"><a href="https://geekmom.com/category/featured-columns/weekly-dc-comics-capsule-reviews/">Weekly DC Comics Capsule Reviews</a></li>
	<li id="menu-item-298243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298243 nv-cat-18275"><a href="https://geekmom.com/category/featured-columns/adventures-instant-potting/">Adventures in Instant Potting</a></li>
	<li id="menu-item-298267" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298267 nv-cat-2703"><a href="https://geekmom.com/category/featured-columns/">View All in Columns</a></li>
</ul>
</li>
<li id="menu-item-298222" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-298222 nv-cat-32"><a href="https://geekmom.com/category/diy/">DIY</a>
<ul class="sub-menu">
	<li id="menu-item-298223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298223 nv-cat-7996"><a href="https://geekmom.com/category/diy/block-of-the-month/">Block of the Month</a></li>
	<li id="menu-item-298224" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298224 nv-cat-129"><a href="https://geekmom.com/category/diy/clothing-and-cosplay/">Clothing and Cosplay</a></li>
	<li id="menu-item-298225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298225 nv-cat-26"><a href="https://geekmom.com/category/diy/cooking-and-recipes/">Cooking and Recipes</a></li>
	<li id="menu-item-298226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298226 nv-cat-4581"><a href="https://geekmom.com/category/diy/pinbusted-or-pintrusted/">PinBusted or PinTrusted</a></li>
	<li id="menu-item-298227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298227 nv-cat-127"><a href="https://geekmom.com/category/diy/printable-fun/">Printable Fun</a></li>
	<li id="menu-item-298265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298265 nv-cat-32"><a href="https://geekmom.com/category/diy/">View All in DIY</a></li>
</ul>
</li>
<li id="menu-item-298229" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-298229 nv-cat-9555"><a href="https://geekmom.com/category/entertainment-geekmom/">Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-298230" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298230 nv-cat-30"><a href="https://geekmom.com/category/entertainment-geekmom/books-entertainment-geekmom/">Books</a></li>
	<li id="menu-item-298231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298231 nv-cat-8985"><a href="https://geekmom.com/category/entertainment-geekmom/comic-books-entertainment-geekmom/">Comic Books</a></li>
	<li id="menu-item-298233" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298233 nv-cat-37"><a href="https://geekmom.com/category/entertainment-geekmom/games/">Games</a></li>
	<li id="menu-item-298234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298234 nv-cat-1999"><a href="https://geekmom.com/category/entertainment-geekmom/music-entertainment-geekmom/">Music</a></li>
	<li id="menu-item-298237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-298237 nv-cat-42"><a href="https://geekmom.com/category/entertainment-geekmom/tv-and-movies/">TV and Movies</a>
	<ul class="sub-menu">
		<li id="menu-item-298238" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298238 nv-cat-4752"><a href="https://geekmom.com/category/entertainment-geekmom/tv-and-movies/forgotten-fandoms/">Forgotten Fandoms</a></li>
		<li id="menu-item-298239" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298239 nv-cat-1974"><a href="https://geekmom.com/category/entertainment-geekmom/tv-and-movies/youtube-and-streaming/">YouTube and Streaming</a></li>
	</ul>
</li>
	<li id="menu-item-298240" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298240 nv-cat-12417"><a href="https://geekmom.com/category/entertainment-geekmom/video-games/">Video Games</a></li>
	<li id="menu-item-298232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298232 nv-cat-2576"><a href="https://geekmom.com/category/entertainment-geekmom/conventions/">Conventions</a></li>
	<li id="menu-item-298266" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-298266 nv-cat-9555"><a href="https://geekmom.com/category/entertainment-geekmom/">View All in Entertainment</a></li>
</ul>
</li>
<li id="menu-item-298264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-298264"><a>Family</a>
<ul class="sub-menu">
	<li id="menu-item-298228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298228 nv-cat-8388"><a href="https://geekmom.com/category/education-geekmom/">Education</a></li>
	<li id="menu-item-298241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298241 nv-cat-27"><a href="https://geekmom.com/category/family/">Family</a></li>
</ul>
</li>
<li id="menu-item-298258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-298258 nv-cat-2402"><a href="https://geekmom.com/category/science/">Science</a>
<ul class="sub-menu">
	<li id="menu-item-298259" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298259 nv-cat-47"><a href="https://geekmom.com/category/science/experiments/">Experiments</a></li>
	<li id="menu-item-298260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298260 nv-cat-12422"><a href="https://geekmom.com/category/science/health-science/">Health</a></li>
	<li id="menu-item-298261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298261 nv-cat-3488"><a href="https://geekmom.com/category/science/summer-science-fun/">Summer Science Fun</a></li>
	<li id="menu-item-298262" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298262 nv-cat-82"><a href="https://geekmom.com/category/science/technology-science/">Technology</a></li>
	<li id="menu-item-298269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298269 nv-cat-2402"><a href="https://geekmom.com/category/science/">View All in Science</a></li>
</ul>
</li>
<li id="menu-item-298235" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-298235 nv-cat-44"><a href="https://geekmom.com/category/travel-entertainment-geekmom/">Travel</a>
<ul class="sub-menu">
	<li id="menu-item-298236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298236 nv-cat-2789"><a href="https://geekmom.com/category/travel-entertainment-geekmom/geeky-states-of-america/">Geeky States of America</a></li>
</ul>
</li>
<li id="menu-item-298253" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-298253 nv-cat-2535"><a href="https://geekmom.com/category/reviews-geekmom/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-298254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298254 nv-cat-2216"><a href="https://geekmom.com/category/reviews-geekmom/apps/">Apps</a></li>
	<li id="menu-item-298255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298255 nv-cat-100"><a href="https://geekmom.com/category/reviews-geekmom/electronics-reviews-geekmom/">Electronics</a></li>
	<li id="menu-item-298256" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298256 nv-cat-55"><a href="https://geekmom.com/category/reviews-geekmom/household-gadgets/">Household Gadgets</a></li>
	<li id="menu-item-298257" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-298257 nv-cat-158"><a href="https://geekmom.com/category/reviews-geekmom/toys-reviews-geekmom/">Toys</a></li>
	<li id="menu-item-298268" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-298268 nv-cat-2535"><a href="https://geekmom.com/category/reviews-geekmom/">View All in Reviews</a></li>
</ul>
</li>
<li id="menu-item-298271" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-298271"><a>Shop</a>
<ul class="sub-menu">
	<li id="menu-item-298309" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-298309"><a href="https://deals.geekdad.com" class="external" rel="nofollow" target="_blank">Daily Deals</a></li>
	<li id="menu-item-298308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-298308"><a href="http://geekdad.bigcartel.com/" class="external" rel="nofollow" target="_blank">GeekMom Merch</a></li>
	<li id="menu-item-330576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330576 nv-cat-18287"><a href="https://geekmom.com/category/holidays/gift-guide/">Gift Guide</a></li>
</ul>
</li>
<li id="menu-item-298270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-298270"><a>GeekMom Info</a>
<ul class="sub-menu">
	<li id="menu-item-298303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298303"><a href="https://geekmom.com/about-geekmom/">About GeekMom</a></li>
	<li id="menu-item-298274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-298274"><a target="_blank" rel="noopener" href="https://geekmom.com/feed/">RSS</a></li>
	<li id="menu-item-298307" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298307"><a href="https://geekmom.com/sponsorsadvertisors/">Advertise on GeekMom</a></li>
	<li id="menu-item-298306" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298306"><a href="https://geekmom.com/prproduct-review-enquiries/">PR/Product Review Enquiries</a></li>
	<li id="menu-item-331227" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-331227"><a href="https://geekmom.com/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-298305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-298305"><a href="https://geekmom.com/crowdfunding-review-guidelines/">Crowdfunding Review Guidelines</a></li>
	<li id="menu-item-330584" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-330584"><a href="https://geekmom.com/geekmom-writers-other-projects/">GeekMom Writers&#8217; Other Projects</a></li>
</ul>
</li>
<li id="menu-item-298272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-298272"><a target="_blank" rel="noopener nofollow" href="https://geekdad.com" class="external">Visit GeekDad</a></li>
</ul></div>					</nav><!-- #site-navigation -->

											<div class="nv-header-search-wrapper">                    
			                <span class="search-main"><a href="javascript:void(0);"><i class="fa fa-search"></i></a></span>
			                <div class="search-form-main nv-clearfix">
				                <form role="search" method="get" class="search-form" action="https://geekmom.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>				            </div>
						</div><!-- .nv-header-search-wrapper -->
									</div>
			</div>
		</div><!-- .nv-header-menu-wrapper -->
</header><!-- .site-header -->
	<div id="content" class="site-content">
		<div class="cv-container">
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-339937" class="post-339937 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment-geekmom category-reviews-geekmom mv-content-wrapper">
	
			<div class="nv-article-thumb">
			<img width="1200" height="900" src="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg" class="attachment-full size-full wp-post-image" alt="creatures season 2 feature" srcset="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg 1200w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature-600x450.jpg 600w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature-1000x750.jpg 1000w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature-768x576.jpg 768w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature-272x204.jpg 272w " sizes="(max-width: 1200px) 100vw, 1200px" data-attachment-id="339939" data-permalink="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/creatures-season-2-feature/" data-orig-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature.jpg" data-orig-size="1200,900" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="creatures season 2 feature" data-image-description="" data-image-caption="" data-medium-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature-600x450.jpg" data-large-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2022/01/creatures-season-2-feature-1000x750.jpg" />		</div><!-- .nv-article-thumb -->
	
	<header class="entry-header">
		<h1 class="entry-title">5 Reasons to Keep Watching &#8216;All Creatures Great and Small&#8217;</h1>		<div class="post-cats-list">
							<span class="category-button nv-cat-9555"><a href="https://geekmom.com/category/entertainment-geekmom/">Entertainment</a></span>
							<span class="category-button nv-cat-2535"><a href="https://geekmom.com/category/reviews-geekmom/">Reviews</a></span>
					</div>
		<div class="entry-meta">
			<span class="posted-on"><a href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/" rel="bookmark"><time class="entry-date published" datetime="2022-01-30T08:00:48-05:00">January 30, 2022</time><time class="updated" datetime="2022-01-31T00:30:39-05:00">January 31, 2022</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://geekmom.com/author/lisa/">Lisa Tate</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content">
		<p class="p2">This month, season 2 of the <em>PBS Masterpiece</em> series <i>All Creatures Great and Small</i> had its U.S. premiere, and I had it pre-purchased and ready-to-go on good old Amazon Prime well in advance.</p>
<p class="p2">This is one of the few series I just couldn’t wait to dive back into for several reasons. Many of these reasons, as well as how much the tales of James Herriot meant to me, I talked about last year in my post <a href="https://geekmom.com/2021/04/all-creatures-great-and-small-a-coming-home-to-darrowby">&#8220;A Coming Home to Darrowby&#8221;</a>.</p>
<p class="p2">Instead of retelling that lengthy story, I&#8217;ll give you just five short reasons I hope everyone is continuing their journey into Darrowby with me this season.</p>
<h2 class="p2">The &#8220;Rewatchability&#8221;</h2>
<p class="p2">First off, the seasons are relatively short. They are seven episodes each. This includes the BBC standard of a season-ending Christmas episode. With an average running time of 50 minutes, you could breeze through the season in a week watching just one or two a night. The binge commitment isn&#8217;t too intense, but it is the content that brings you back. We rewatched season 1 before the second season was available for us, and even knowing all the plot details, the jokes, and revealing moments, it was still just as enjoyable. I can&#8217;t say this about many of my other favorite shows or movies, as the &#8220;surprise factor&#8221; is always a big draw for me. Returning to familiar territory and being just as entertained was a plus.</p>
<h2 class="p2">The Laughs</h2>
<p class="p2">One of the main reasons people are drawn to animal-centric stories and movies is we all know when it comes to scene-chewing stars, animals will always outshine humans. This was true even when I first read James Herriot&#8217;s books. From the return of Tricky Woo to the showdown with an angry pig, it is always a hilarious reminder that animals rule their world… we just live in it. Herriot&#8217;s look at the lighter side of his work was so well-written, it helped me make it through the books&#8217; inevitable heartbreak of dealing with the loss of a pet or family member, to living &#8220;between the wars.&#8221; Life is filled with hardships and sadness, neither of which is ignored in these tales, but it also has plenty of joy and fun. The show also makes sure all the humor isn&#8217;t focused on experiences with animals. The human actors get many chances to shine on their own. It is the story that will draw you in, but it&#8217;s the sweet humor that will keep you around.</p>
<h2 class="p2">The Acting</h2>
<p class="p2">Even series I enjoy thoroughly tend to have one or two actors who just make me cringe, be it their voice, their mannerisms, or the way they deliver their lines. That is just human nature, I guess. We all have that closet critic in us when watching a favorite series. I have yet to encounter that person on <i>All Creatures Great and Small</i>, even the ones playing characters that aren&#8217;t appealing. The primary cast of Nicholas Ralph, Samuel West, Anna Madeley, Callum Woodhouse, and Rachel Shenton have all fallen into their roles even better this second season, and there have been no weak links in the supporting cast members (at least so far). My one worry was the replacement of Dame Diana Rigg as Mrs. Pumphrey. Rigg, who passed away before the filming of the second season, is a tough act to follow, and her replacement, Patricia Hodge, is noticeably younger. Other than that, she seems to be making the role her own, while making sure her co-star Derek (Tricky Woo) takes the lead. This is a case where everyone genuinely looks like they are loving being part of this series, and it shows.</p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/QoSYCbOj49M?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></div>
<h2>The Sincerity</h2>
<p class="p2">So often, when a series or movie representing a different era is made today (including those based on well-loved books), it can go in one of two directions. It can be so innocent and sweet it is nauseatingly saccharine. On the other side, it can so overworked for today&#8217;s sensibilities it is hardly recognizable to those who loved the original source material. Either direction can end up a bit preachy. This has not been the case here. There is a loving and sincere effort to stay true to the spirit of Herriot&#8217;s original stories, yet with enough changes to keep the story flowing and interesting. There is no agenda of keeping every tiny detail of the book exactly intact, or in trying to rewrite the history of the era. It only wants to tell us a good story. Fortunately, James Herriot’s tales give us a wonderfully welcoming starting point to do this. If you have never read Herriot&#8217;s books, you can still enjoy this story. If you are a long-time fan, you will still be satisfied with this new version.</p>
<h2>The Escape</h2>
<p class="p2">As I mentioned in my look at season 1, the actors and animals are almost upstaged by the gorgeous landscape of the Yorkshire Dales and the historic Grassington playing the part of Darrowby. One of the reasons we get absorbed in certain stories is good world-building, be it traveling to another galaxy or another time. After watching just a couple of episodes of the original season, my old desire to someday visit the Yorkshire Dales was renewed. By this point into season 2, I just want to spend days—weeks even—exploring the region. I want to drive or walk along the green moss-covered rock walls. I want to place my feet in the icy river waters, and stroll along the main street on a star-filled night. The treatment of time and place is so thoughtfully done, by the time you finish the series, you may feel the longing as well to visit Skeldale House for a warm tea or cozy breakfast or join in the gatherings at the Drovers Arms (the Devonshire Hotel in the real world). The setting just wraps around you like the arms of a long-lost family member, and you won&#8217;t want to leave.</p>
<p class="p2">If you haven&#8217;t yet found time to return to Darrowby, I still recommend you do so. The series has already been renewed for a third and fourth season. Bring along your Wellingtons and good jacket (for it does get chilly), a tissue or two (there will be some tears), and most of all an open heart to embrace the warmth and love that continues to go into this delightful series.</p>
<div class="cb_p6_patreon_button" style="text-align:center !important;margin-top:15px;margin-bottom:15px;"><div class="cb_p6_message_over_post_button" style="font-size:24px;margin-top:10px;margin-bottom:10px;">Liked it? Take a second to support GeekMom and GeekDad on Patreon!</div><a rel="nofollow" href="https://www.patreon.com/geekdad?utm_content=post_button&utm_medium=patron_button_and_widgets_plugin&utm_campaign=&utm_term=&utm_source=https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/"><img style="margin-top: 10px;margin-bottom: 10px;max-width:200px;width:100%;height:auto;" src="https://149461325.v2.pressablecdn.com/wp-content/plugins/patron-button-and-widgets-by-codebard/images/become_a_patron_button.png"></a></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-339937" class="share-twitter sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-339937" class="share-facebook sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-339937" class="share-linkedin sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-339937" class="share-pinterest sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-339937" class="share-skype sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://geekmom.com/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	</div><!-- .entry-content -->

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->

</article><!-- #post-339937 -->
	<nav class="navigation post-navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://geekmom.com/2022/01/preparing-for-a-snow-day/" rel="prev">Preparing for a Snow Day</a></div></div>
	</nav><div class="nv-related-section-wrapper"><h2 class="nv-related-title nv-clearfix">Related Posts</h2><div class="nv-related-posts-wrap nv-clearfix">				<div class="nv-single-post nv-clearfix">
					<div class="nv-post-thumb">
						<a href="https://geekmom.com/2017/03/an-introverts-lessons-from-the-con-days-2-3-and-4/">
							<img width="305" height="153" src="https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/12/EmeraldCityComicCon-1.jpg" class="attachment-news-vibrant-block-medium size-news-vibrant-block-medium wp-post-image" alt="" loading="lazy" srcset="https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/12/EmeraldCityComicCon-1.jpg 1000w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/12/EmeraldCityComicCon-1-300x150.jpg 300w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/12/EmeraldCityComicCon-1-768x384.jpg 768w " sizes="(max-width: 305px) 100vw, 305px" data-attachment-id="294160" data-permalink="https://geekmom.com/2017/03/an-introverts-lessons-from-the-con-days-2-3-and-4/emeraldcitycomiccon-2/" data-orig-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/12/EmeraldCityComicCon-1.jpg" data-orig-size="1000,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EmeraldCity" data-image-description="" data-image-caption="&lt;p&gt;c. ReedPop &lt;/p&gt;
" data-medium-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/12/EmeraldCityComicCon-1-300x150.jpg" data-large-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2017/12/EmeraldCityComicCon-1.jpg" />						</a>
					</div><!-- .nv-post-thumb -->
					<div class="nv-post-content">
						<h3 class="nv-post-title small-size"><a href="https://geekmom.com/2017/03/an-introverts-lessons-from-the-con-days-2-3-and-4/">An Introvert&#8217;s Lessons From the Con: Days 2, 3, and 4</a></h3>
						<div class="nv-post-meta">
							<span class="posted-on"><a href="https://geekmom.com/2017/03/an-introverts-lessons-from-the-con-days-2-3-and-4/" rel="bookmark"><time class="entry-date published" datetime="2017-03-16T06:00:14-04:00">March 16, 2017</time><time class="updated" datetime="2017-12-15T22:21:55-05:00">December 15, 2017</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://geekmom.com/author/shiri-sondheimer/">Shiri Sondheimer</a></span></span>						</div>
					</div><!-- .nv-post-content -->
				</div><!-- .nv-single-post -->
					<div class="nv-single-post nv-clearfix">
					<div class="nv-post-thumb">
						<a href="https://geekmom.com/2021/10/31-days-of-halloween-games-echo-generation/">
							<img width="305" height="207" src="https://149461325.v2.pressablecdn.com/wp-content/uploads/2021/10/31-days-halloween-games-echo-generation-02-305x207.jpg" class="attachment-news-vibrant-block-medium size-news-vibrant-block-medium wp-post-image" alt="" loading="lazy" data-attachment-id="338229" data-permalink="https://geekmom.com/2021/10/31-days-of-halloween-games-echo-generation/31-days-halloween-games-echo-generation-02/" data-orig-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2021/10/31-days-halloween-games-echo-generation-02.jpg" data-orig-size="1200,900" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 6s&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1632866120&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.15&quot;,&quot;iso&quot;:&quot;500&quot;,&quot;shutter_speed&quot;:&quot;0.058823529411765&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="31-days-halloween-games-echo-generation-02" data-image-description="" data-image-caption="" data-medium-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2021/10/31-days-halloween-games-echo-generation-02-600x450.jpg" data-large-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2021/10/31-days-halloween-games-echo-generation-02-1000x750.jpg" />						</a>
					</div><!-- .nv-post-thumb -->
					<div class="nv-post-content">
						<h3 class="nv-post-title small-size"><a href="https://geekmom.com/2021/10/31-days-of-halloween-games-echo-generation/">31 Days of Halloween Games: &#8216;Echo Generation&#8217;</a></h3>
						<div class="nv-post-meta">
							<span class="posted-on"><a href="https://geekmom.com/2021/10/31-days-of-halloween-games-echo-generation/" rel="bookmark"><time class="entry-date published" datetime="2021-10-21T06:00:10-04:00">October 21, 2021</time><time class="updated" datetime="2021-10-20T22:27:15-04:00">October 20, 2021</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://geekmom.com/author/evil-genius-mum/">Evil Genius Mum</a></span></span>						</div>
					</div><!-- .nv-post-content -->
				</div><!-- .nv-single-post -->
					<div class="nv-single-post nv-clearfix">
					<div class="nv-post-thumb">
						<a href="https://geekmom.com/2018/08/nintendo-labo-vehicle-kit-5-more-essential-things-to-know/">
							<img width="305" height="172" src="https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2.jpg" class="attachment-news-vibrant-block-medium size-news-vibrant-block-medium wp-post-image" alt="Nintendo Labo" loading="lazy" srcset="https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2.jpg 1200w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2-600x338.jpg 600w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2-768x432.jpg 768w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2-1000x563.jpg 1000w , https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2-800x450.jpg 800w " sizes="(max-width: 305px) 100vw, 305px" data-attachment-id="307927" data-permalink="https://geekmom.com/2018/08/nintendo-labo-vehicle-kit-5-more-essential-things-to-know/nintendo-labo-2/" data-orig-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2.jpg" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone X&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1534872656&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4&quot;,&quot;iso&quot;:&quot;40&quot;,&quot;shutter_speed&quot;:&quot;0.066666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Nintendo Labo 2" data-image-description="" data-image-caption="" data-medium-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2-600x338.jpg" data-large-file="https://149461325.v2.pressablecdn.com/wp-content/uploads/2018/08/Nintendo-Labo-2-1000x563.jpg" />						</a>
					</div><!-- .nv-post-thumb -->
					<div class="nv-post-content">
						<h3 class="nv-post-title small-size"><a href="https://geekmom.com/2018/08/nintendo-labo-vehicle-kit-5-more-essential-things-to-know/">Nintendo Labo: Vehicle Kit &#8212; 5 (More) Essential Things to Know</a></h3>
						<div class="nv-post-meta">
							<span class="posted-on"><a href="https://geekmom.com/2018/08/nintendo-labo-vehicle-kit-5-more-essential-things-to-know/" rel="bookmark"><time class="entry-date published" datetime="2018-08-25T12:00:03-04:00">August 25, 2018</time><time class="updated" datetime="2018-08-26T14:37:41-04:00">August 26, 2018</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://geekmom.com/author/karen-walsh/">Karen Walsh</a></span></span>						</div>
					</div><!-- .nv-post-content -->
				</div><!-- .nv-single-post -->
	</div><!-- .nv-related-posts-wrap --></div><!-- .nv-related-section-wrapper -->
		</main><!-- #main -->
	</div><!-- #primary -->


<aside id="secondary" class="widget-area" role="complementary">
	<section id="custom_html-17" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Widget Shortcode --><div id="text-27" class="widget widget_text widget-shortcode area-news_vibrant_home_middle_right_aside_area "><h2 class="widgettitle">GeekMom Masthead</h2>			<div class="textwidget"><h4>Editor-in-Chief</h4>
<p><a href="http://geekmom.com/author/jenny-bristol/" data-mce-href="http://geekmom.com/author/jenny-bristol/">Jenny Bristol</a><br data-mce-bogus="1"></p>
<h4>Publisher</h4>
<p><a href="http://geekdad.com/author/geekdad-ken/" data-mce-href="http://geekdad.com/author/geekdad-ken/" class="external" rel="nofollow" target="_blank">Ken Denmead</a><br data-mce-bogus="1"></p>
<h4>Senior Editors</h4>
<p><a href="http://geekmom.com/author/sophie-brown/" data-mce-href="http://geekmom.com/author/sophie-brown/">Sophie Brown</a>, <a href="http://geekmom.com/author/patricia-vollmer/" data-mce-href="http://geekmom.com/author/patricia-vollmer/">Patricia Vollmer</a>, <a href="https://geekdad.com/author/mblum/" data-mce-href="https://geekdad.com/author/mblum/" class="external" rel="nofollow" target="_blank">Matt Blum</a>, <a href="https://geekdad.com/author/geekdadz/" data-mce-href="https://geekdad.com/author/geekdadz/" class="external" rel="nofollow" target="_blank">Z</a>, <a href="https://geekdad.com/author/jonathanhliu/" data-mce-href="https://geekdad.com/author/jonathanhliu/" class="external" rel="nofollow" target="_blank">Jonathan H. Liu</a><br data-mce-bogus="1"></p>
<h4>Core Contributors</h4>
<p><a href="http://geekmom.com/author/rebecca/" data-mce-href="http://geekmom.com/author/rebecca/">Rebecca Angel</a>, <a href="http://geekmom.com/author/judy/" data-mce-href="http://geekmom.com/author/judy/">Judy Berna</a>, <a href="http://geekmom.com/author/nivi-engineer/" data-mce-href="http://geekmom.com/author/nivi-engineer/">Nivi Engineer</a>, <a href="http://geekmom.com/author/evil-genius-mum/" data-mce-href="http://geekmom.com/author/evil-genius-mum/">Evil Genius Mum</a>, <a href="http://geekmom.com/author/marziah-karch/" data-mce-href="http://geekmom.com/author/marziah-karch/">Marziah Karch</a>, <a href="https://geekmom.com/author/majk/" data-mce-href="https://geekmom.com/author/majk/">M.J. Kaufmann</a>, <a href="https://geekmom.com/author/elizabethmacandrew/" data-mce-href="https://geekmom.com/author/elizabethmacandrew/">Elizabeth MacAndrew</a>, <a href="http://geekmom.com/author/melanie-2/" data-mce-href="http://geekmom.com/author/melanie-2/">Melanie Meadors</a>,&nbsp;<a href="https://geekmom.com/author/kalimoulton/" data-mce-href="https://geekmom.com/author/kalimoulton/">Kali Moulton</a>, <a href="http://geekmom.com/author/sarah-pinault/" data-mce-href="http://geekmom.com/author/sarah-pinault/">Sarah Pinault</a>, <a href="https://geekmom.com/author/cathe/" data-mce-href="https://geekmom.com/author/cathe/">Cathé Post</a>, <a href="http://geekmom.com/author/ruth-suehle/" data-mce-href="http://geekmom.com/author/ruth-suehle/">Ruth Suehle</a>, <a href="http://geekmom.com/author/dakster-sullivan/" data-mce-href="http://geekmom.com/author/dakster-sullivan/">Dakster Sullivan</a>, <a href="http://geekmom.com/author/lisa/" data-mce-href="http://geekmom.com/author/lisa/">Lisa Tate</a>, <a href="http://geekmom.com/author/karen-walsh/" data-mce-href="http://geekmom.com/author/karen-walsh/">Karen Walsh</a>, and <a href="http://geekmom.com/author/amy-weir/" data-mce-href="http://geekmom.com/author/amy-weir/">Amy Weir</a><br data-mce-bogus="1"></p>
<h4>Occasional Contributors</h4>
<p><a href="https://geekmom.com/author/melissahayes/" data-mce-href="https://geekmom.com/author/melissahayes/">Missy Hayes</a>, <a href="http://geekmom.com/author/claire-jennings/" data-mce-href="http://geekmom.com/author/claire-jennings/">Claire Jennings</a>, <a href="https://geekmom.com/author/jennmac/" data-mce-href="https://geekmom.com/author/jennmac/">Jenn Mac</a>, and <a href="https://geekmom.com/author/andrea/" data-mce-href="https://geekmom.com/author/andrea/">Andrea Schwalm</a><br data-mce-bogus="1"></p>
<h4>Official GeekMom Pet</h4>
<p><a href="http://geekmom.com/author/fran/" data-mce-href="http://geekmom.com/author/fran/">Fran Wilde</a><br data-mce-bogus="1"></p>
<h4>Associate Publishers*</h4>
<p><a href="http://patreon.com/geekdad" data-mce-href="http://patreon.com/geekdad" class="external" rel="nofollow" target="_blank">Tim Johnides, Jeff Williams, Dante Lauretta, Magnus Dahlsröm, Jayson Peters, David Michael, Gerry Tolbert, Andrew Smith, Ray Wehrs, Joel Becker, Scott Gaeta, Beth Kee, Joey Mills, talkie_tim, Danny Marquardt, Adam Bruski, John Bain, Bill Moore, Adam Frank, Lacey Hays, Peter Morson, James Needham, Matt Fleming, Adam Anderson, Jim Reynolds, Seiler Hagan, Bryan Wade, Petrov Neutrino, Jay Shapiro</a><br data-mce-bogus="1"></p>
</div>
		</div><!-- /Widget Shortcode --></div></section><section id="custom_html-18" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="image-container">
        <img src="https://s3.amazonaws.com/4moms-product-thumbnails/rR_multi_front.jpg" class="product-img" data-src="https://s3.amazonaws.com/4moms-product-thumbnails/rR_multi_front.jpg" alt="">
</div>
                            <a href="https://www.pjatr.com/t/Qz9KRUNIP0NJQkVJRj9KRUNI?url=http%3A%2F%2Fshop.4moms.com%2Fshop-rockaroo%3Fcolor%3Dmulti" class="name external" title="4moms rockaRoo Multi Plush baby swing" target="_blank" rel="noopener nofollow">4moms rockaRoo Multi Plush baby swing</a>
<p>
        The 4moms rockaRoo provides the front to back gliding motion that babies love, in a com...    <a href="https://www.pjatr.com/t/Qz9KRUNIP0NJQkVJRj9KRUNI?url=http%3A%2F%2Fshop.4moms.com%2Fshop-rockaroo%3Fcolor%3Dmulti" class="external" rel="nofollow" target="_blank">[More]</a>
</p>
<div class="price">Price: <span>$179.99</span></div>
<div class="action"><a href="https://www.pjatr.com/t/Qz9KRUNIP0NJQkVJRj9KRUNI?url=http%3A%2F%2Fshop.4moms.com%2Fshop-rockaroo%3Fcolor%3Dmulti" class="external" rel="nofollow" target="_blank">Buy Now</a></div>
                        </div></section></aside><!-- #secondary -->

		</div><!-- .cv-container -->
	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo"><div class="bottom-footer nv-clearfix"><div class="cv-container">		<div class="site-info">
			<span class="nv-copyright-text">
				News Vibrant			</span>
			<span class="sep"> | </span>
			Theme: news-vibrant by <a href="http://codevibrant.com/" rel="designer nofollow" target="_blank" class="external">CodeVibrant</a>.		</div><!-- .site-info -->
		<nav id="footer-navigation" class="footer-navigation" role="navigation">
					</nav><!-- #site-navigation -->
</div><!-- .cv-container --></div> <!-- bottom-footer --></footer><!-- #colophon --><div id="nv-scrollup" class="animated arrow-hide"><i class="fa fa-chevron-up"></i></div></div><!-- #page -->


<!-- WP Audio player plugin v1.9.6 - https://www.tipsandtricks-hq.com/wordpress-audio-music-player-plugin-4556/ -->
    <script type="text/javascript">
        soundManager.useFlashBlock = true; // optional - if used, required flashblock.css
        soundManager.url = 'https://geekmom.com/wp-content/plugins/compact-wp-audio-player/swf/soundmanager2.swf';
        function play_mp3(flg, ids, mp3url, volume, loops)
        {
            //Check the file URL parameter value
            var pieces = mp3url.split("|");
            if (pieces.length > 1) {//We have got an .ogg file too
                mp3file = pieces[0];
                oggfile = pieces[1];
                //set the file URL to be an array with the mp3 and ogg file
                mp3url = new Array(mp3file, oggfile);
            }

            soundManager.createSound({
                id: 'btnplay_' + ids,
                volume: volume,
                url: mp3url
            });

            if (flg == 'play') {
                    soundManager.play('btnplay_' + ids, {
                    onfinish: function() {
                        if (loops == 'true') {
                            loopSound('btnplay_' + ids);
                        }
                        else {
                            document.getElementById('btnplay_' + ids).style.display = 'inline';
                            document.getElementById('btnstop_' + ids).style.display = 'none';
                        }
                    }
                });
            }
            else if (flg == 'stop') {
    //soundManager.stop('btnplay_'+ids);
                soundManager.pause('btnplay_' + ids);
            }
        }
        function show_hide(flag, ids)
        {
            if (flag == 'play') {
                document.getElementById('btnplay_' + ids).style.display = 'none';
                document.getElementById('btnstop_' + ids).style.display = 'inline';
            }
            else if (flag == 'stop') {
                document.getElementById('btnplay_' + ids).style.display = 'inline';
                document.getElementById('btnstop_' + ids).style.display = 'none';
            }
        }
        function loopSound(soundID)
        {
            window.setTimeout(function() {
                soundManager.play(soundID, {onfinish: function() {
                        loopSound(soundID);
                    }});
            }, 1);
        }
        function stop_all_tracks()
        {
            soundManager.stopAll();
            var inputs = document.getElementsByTagName("input");
            for (var i = 0; i < inputs.length; i++) {
                if (inputs[i].id.indexOf("btnplay_") == 0) {
                    inputs[i].style.display = 'inline';//Toggle the play button
                }
                if (inputs[i].id.indexOf("btnstop_") == 0) {
                    inputs[i].style.display = 'none';//Hide the stop button
                }
            }
        }
    </script>
    
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/geekmom.com\/2022\/01\/5-reasons-to-keep-watching-all-creatures-great-and-small\/":339937};
	</script>
							<div id="sharing_email" style="display: none;">
		<form action="/2022/01/5-reasons-to-keep-watching-all-creatures-great-and-small/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=5-reasons-to-keep-watching-all-creatures-great-and-small" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://149461325.v2.pressablecdn.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.6.0' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/random-banner/assets/script/bc_rb_global.js?ver=4.1.4' id='bc_rb_global_script-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/random-banner/assets/script/owl.carousel.js?ver=4.1.4' id='owl.carousel-script-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/js/navigation.js?ver=1.0.12' id='news-vibrant-navigation-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/library/sticky/jquery.sticky.js?ver=20150416' id='jquery-sticky-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/library/sticky/sticky-setting.js?ver=20150309' id='nv-sticky-menu-setting-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/js/skip-link-focus-fix.js?ver=1.0.12' id='news-vibrant-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/library/lightslider/js/lightslider.min.js?ver=1.1.6' id='lightslider-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.0' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.13.0' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/themes/news-vibrant/assets/js/nv-custom-scripts.js?ver=1.0.12' id='news-vibrant-custom-script-js'></script>
<script type='text/javascript' id='jetpack-facebook-embed-js-extra'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js?ver=10.6-beta' id='jetpack-facebook-embed-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0' id='jetpack-twitter-timeline-js'></script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/jetpack/modules/theme-tools/responsive-videos/responsive-videos.min.js?ver=1.3' id='jetpack-responsive-videos-min-script-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://149461325.v2.pressablecdn.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.6-beta' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>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</script>
		<script type="text/javascript">
			(function() {
			var t   = document.createElement( 'script' );
			t.type  = 'text/javascript';
			t.async = true;
			t.id    = 'gauges-tracker';
			t.setAttribute( 'data-site-id', '5f04d87153ede54f9dd3ad34' );
			t.src = '//secure.gaug.es/track.js';
			var s = document.getElementsByTagName( 'script' )[0];
			s.parentNode.insertBefore( t, s );
			})();
		</script>
		<script src='https://stats.wp.com/e-202205.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.6-beta',blog:'34256382',post:'339937',tz:'-5',srv:'geekmom.com'} ]);
	_stq.push([ 'clickTrackerInit', '34256382', '339937' ]);
</script>

</body>
</html>